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Bug Fixes

LightTools 4.0 Service Release 1 (SR1) contains numerous bug fixes, as well as a variety of 
enhancements. Two of the bug fixes, described below, are especially important to note and to 
implement by applying this service release.

� Ray Tracing: This service release fixes a bug that caused a substantial slowdown in ray tracing 
speed. The bug affects all users who use a green (parallel port) dongle as a LightTools security 
device. If you use a green dongle as your LightTools security device, we encourage you to apply 
LightTools 4.0 SR1 as soon as possible.

� Reflective Scatter Model (non-Lambertian): This service release also fixes a bug that affects 
some models with reflective scattering surfaces. In previous versions, when rays were incident 
from a material with an index of refraction greater than 1, LightTools scaled the scatter 
distribution using the refractive index of the material. With this fix, when a ray is incident on a 
reflective scattering surface, the ray is reflected using a distribution that is independent of the 
material the ray is in. (Transmissive scatter models and models in which rays are scattered from 
a material with an index of 1 are not affected by this bug.)

Enhancements

Enhancements to the LightTools product are described in the following sections.

New Preference Options

On the Preferences dialog box, new options under the Defaults heading allow you to control the 
default values for materials and optical properties of elements you will be creating in your 
LightTools session. 

Additional Options for Optical Properties Defaults
Seven subheadings were added under the Optical Properties heading on the Preferences dialog box, 
as shown in the following figure.
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Dividing Optical Properties default settings into separate tabs allows you to vary the default values 
for each of the surface types, as described below.

� User Property Zones for newly created property zones. This replaces the (only) default 
Optical Properties option in the previous LightTools release.

� Transmissive for the front and rear surfaces of lenses and the transmissive surfaces of other 
optical elements.

� Reflective for the front surfaces of new mirrors and the reflective surfaces of prisms.

� Source for all surfaces of new light sources.

� Imported Geometry for all surfaces of all objects created from a new import of SAT, IGES, 
STEP, or CATIA formats.

� Absorbing for edge and flat surfaces of new lenses, the end cap surfaces of new prisms, etc.

� Mechanical for all surfaces of new mechanical elements.

New Default Page for Materials
The Materials page, displayed when you click Materials under the Defaults heading on the 
Preferences dialog box, allows you to specify the catalog and material to be used as a default when 
you create new elements of the type listed below. 

� Optical -- for lenses, prisms, or other elements created using the buttons on the Elements palette

� Mechanical -- for elements created using the buttons on the 3D Objects palette, such as 
MBlock, MSphere, etc.

� Imported Geometry -- for materials of elements imported from other CAD formats

� Sources -- for light sources

The default catalog and value provided for each element type when you install LightTools is shown 
in the following figure.
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Changes to Default Values on Preferences Dialog Box
Default values for the following options have changed, as shown in the following table.

Probabilistic Ray Tracing Option for Scattering Optical Properties
For scattering surfaces, you can set the Ray Propagation Direction to Reflect, Transmit, or Both. 
When you select Reflect or Transmit, LightTools traces rays in only one direction after they interact 
with the surface. When you select Both, LightTools can trace both reflected and transmitted rays, 
but you also have the option of activating the Probabilistic Ray Split option, which causes 
LightTools to randomly choose and trace only one of the two rays, (either reflected or transmitted) 
at each split. Probabilistic ray tracing is done in such a way that, for a large number of rays traced, 
a proper power balance is observed for both transmitted and reflected rays. For many systems, 
probabilistic ray splitting may greatly improve performance.

In previous releases, the default setting for Probabilistic Ray Split option was off. In this release, 
when you set the Ray Propagation Direction to Both, the default setting for Probabilistic Ray Split 
is on, and the message, �Probabilistic ray tracing is activated� is displayed in the Console Window.

This change does not affect existing LightTools models. If you restore a LightTools model in which 
the Ray Propagation Direction is set to Both and the Probabilistic Ray Split option is turned off, the 
Probabilistic Ray Split option remains off.

 Option Location Old Value New Value

Probabilistic Ray Split for 
scattering surfaces
For more information about 
the effects of this change, see 
Probabilistic Ray Tracing 
Option for Scattering 
Optical Properties on page 
3.

Defaults > Optical 
Properties > Scattering 
Surface tabs: Lambertian 
Scattering, Cos Nth 
Scattering, or Gaussian 
Scattering tab)

Off On 
Note: The new value 
applies only when the 
Ray Propagation 
Direction is set to 
Both.

Ray Fan Spacing Defaults > Ray Trace tab Linear Equi-angle

Ray Grid Spacing Defaults > Ray Trace tab Linear Equi-angle

Ray Trace Info Defaults > Simulation tab Show Simulation 
Rays

Preview Rays 
(only the name of the 
option changed)

Ray Trace Info Defaults > Simulation tab Show Simulation 
Info

Show Ray Report
(only the name of the 
option changed)

Units (for receivers) Defaults > Receiver tab Radiometric 
Power

Photometric Flux

Units (for light sources) Defaults > Source tab Radiometric 
Power

Photometric Flux

Enable Foci Rendering General Preferences > 
System tab

On Off
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Note: If you do not want to use probabilistic ray splitting, you can turn it off. If you turn off the 
Probabilistic Ray Split option when the Ray Propagation Direction is set to Both, you override the 
default setting. 

Starting Point Classification for Light Sources

A new option is available for light sources to classify the rays� starting points.

When you run a simulation, LightTools has to determine the medium in which the starting points of 
the rays reside. Starting Point Classification options let you specify the method LightTools uses to 
do this. When you choose the new option, Semi-automatic, LightTools does not have to classify the 
starting point of every light source ray; instead, LightTools starts a small number of rays (fewer than 
ten) from each source, and, if all of them start in the same region, this region becomes the default 
for starting point classification. Using fewer rays to determine the material can make the simulation 
faster, especially for models with imported geometry. 

Although Semi-automatic mode is faster than Automatic mode, Semi-automatic mode cannot 
accurately classify the starting material in all situations. For example, if there is some overlap 
between the source and another element, you should use Automatic mode; however, if there is no 
overlap between the source and another element, Semi-automatic mode is the better choice.

Note: Because light sources are fully contained in one medium (e.g., air, epoxy) in most models, 
the new default setting for starting point classification option is Semi-automatic. In previous 
releases, the default setting was Automatic. Also, the light sources included with LightTools (as 
Library elements and otherwise) have the starting point classification option set to Semi-automatic.

You can change the setting for the Starting Point Classification on the Properties dialog box, which 
controls properties for the selected source. You can also change the default setting for Starting Point 
Classification on the Preferences dialog box, which applies to all newly created sources. To change 
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the default setting for Starting Point Classification, right-click in the design view and select View 
Preferences on the shortcut menu; then, expand the Defaults heading and click Source item below 
the Defaults heading.

Layer Name Displayed on Properties Dialog Box

The name associated with a layer, previously displayed only on the Layers tab of the Preferences 
dialog box, is now also displayed on the Display tab of the Properties dialog box for a selected 
element, as shown in the following figure.

Default Setting Changed for Dummy Planes 

For dummy planes, the default setting for Clip Rays to Boundary option is now on (enabled). If you 
would like to change the setting, select the dummy plane, right-click, and select Properties on the 
shortcut menu. Click on the Controls tab to see the Clip Rays to Boundary option, which is in the 
Ray Trace section at the bottom of the tab, shown in the following figure.

Changes to Glass Catalogs

Note: The LightTools glass database does not support glass names with special characters, such as 
hyphens. Glass names that include a hyphen in the manufacturer�s catalog are written without the 
hyphen in LightTools (e.g., S-FTL10 is written SFTL10).

Corning France Glass Catalog
One new glass has been added: C0550. This glass is commonly used for the fabrication of molded 
glass aspheres. In addition, the availability codes for the other glasses in the database have been 
updated with the most current information.
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Ohara Glass Catalog
Six new glasses have been added to the Ohara glass catalog (LAH80, PBH55, S-BSM21, 
S-NBM51, S-TIH20, and an i-line glass PBM18Y). Previously, all Ohara i-line glasses were 
defined using a Laurent�s dispersion equation. In LightTools 4.0 SR1, these have been modified to 
use a more accurate Sellmeier dispersion equation. In addition, the price and availability 
information for all Ohara glasses has been updated in LightTools 4.0 SR1.

Ohara has recently modified the dispersion coefficients of seven current glasses, which resulted in 
small changes to their computed indices. The refractive index changes are very small within the 
visible region, but may be more significant if used in the UV or IR. The glasses impacted are: 
S-BSM18, S-BSM81, S-FPL51, S-LAH55, S-LAH79, S-LAL10, and S-TIH53. The dispersion 
coefficients for these glasses have been updated to the latest information in LightTools 4.0 SR1. 

Schott Glass Catalog
Twelve new glasses have been added to the Schott glass catalog (B-270, KZFS12, N-LAF35, 
N-LAF36, N-LAK33A, N-LAK34, N-LASF45, N-LASF46, N-PK52A, N-SF19, N-SF57, and 
N-SF57HHT). In addition, the price and availability information for all Schott glasses has been 
updated in LightTools 4.0 SR1.

Schott recently modified the dispersion coefficients for one glass, N-LASF45, which resulted in a 
very small change to its computed indices in the ultraviolet. The dispersion coefficient for this glass 
has been updated to the latest values in LightTools 4.0 SR1.

Online Help and Documentation Improvements

The following features have been added to the LightTools online help system:

� Browse buttons -- let you page through the help topics as though they were pages in a book. The 
left- and right-pointing browse button arrows are at the top and bottom of each help screen, as 
shown in the following figure.

� Forward button -- lets you jump to a previously displayed help screen (enabled only after you 
have used the Back button). Although the Back button was available in the previous release, the 
Forward button was inadvertently suppressed from display. As in previous releases, the options 
for moving forward and back in the sequence of previously displayed help screens is also 
available from the Options menu.
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� The LightTools API Reference Guide and the LightTools Macro User�s Guide are now included 
in both the online help system and the Electronic Documentation Library. In previous releases, 
these books were included only in the Electronic Documentation Library (Adobe Acrobat PDF 
files). You can now use the Search feature in either system to find information contained in 
these books.

� To access the online help system, select the menu Help > Contents and Index or click 
the Help button on a dialog box.

� To access the Electronic Documentation Library, select the menu Help > Electronic 
Documentation Library and select a book title.

Forward and Back 
buttons jump to 
previously displayed help 

Browse buttons let you 
display the next or previous 
help screen in the sequence
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